NodeIDs empty

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #545 Reply
    MrWeedster
    Guest

    Hi.
    I ordered two sets of the xbee modules to test the chat funcionality.
    I configured them both as described using the same PAN IDs (It also works if i set the node that acts as “join network” as PANID 0)
    When i type ‘listnodes’ in beechat, it says “Unknown NodeID found:” missing the NodeID.
    When i type ‘changeid random’ it doesn’t generate a NodeID, it’s still empty.
    When i type ‘changeid’ it seems as there should be a dialouge where i put in the NodeID, but it skips that resuming to the command prompt

    #546 Reply
    3iWEvuKEag
    Keymaster

    Hey there,
    PAN ID is the channel, this means all nodes must be on the same PAN ID to be able to “hear” each other.
    Only one XBee per channel may act as “Form network” this is called the network coordinator.

    To fix the problem you are describing you must set a NodeID for the XBee modules, this can be done by plugging them in, and typing “changeid”. This will allow you to change the name of your XBee module. Let me know if it works!

    • This reply was modified 5 months ago by 3iWEvuKEag. Reason: Changed "Join network" to "Form network"
    #551 Reply
    MrWeedster
    Guest

    Hi. Ok then i set both modules to the same channel.
    Using ‘changeid’ doesn’t work as i stated in the first post, it stays empty.

    #555 Reply
    3iWEvuKEag
    Keymaster

    In that case, try changing the node IDs through XCTU, it should work through that. Thank you for letting me know about that bug, I will add it to improvements for version 0.2.

    EDIT FROM MY PREVIOUS POST:
    I earlier said only one device in the network could act as “Join network”, I got it mixed up, sorry for that. That’s not the case. Up to 65,000 devices can join a network, however there can only be ONE “Form network”, that is, the coordinator. Wanted to mention it in case you changed both devices to “Join network”. One of them MUST create the network! Again, let me know if you run into some issues I am more than happy to help.

    • This reply was modified 5 months ago by 3iWEvuKEag.
    #561 Reply
    MrWeedster
    Guest

    Ok i set the node IDs manually and it works so far they can see each other. However, the chat function does nothing. I exchanged the keys with genkey/sendkey, then used the chat function. It just returned to the beechat prompt without output

    #562 Reply
    3iWEvuKEag
    Keymaster

    I am almost certain you are having an issue with permissions within the folder. It’s likely you do not have permissions to read/write in the folder thus BeeChat cannot create files or folders through bash utilities.

    #565 Reply
    3iWEvuKEag
    Keymaster

    If you still have problems, please let me know, I will try and help you as much as I can.
    Here is my qTox ID in case you want to get in touch with me through instant messaging:
    6396D9BD34786DC8319B2012141A26966A725A41C9E4D07BF77F53CDCC670B5754EE4F5E9100

    https://qtox.github.io/ (download link)

    #659 Reply
    MrWeedster
    Guest

    Hi.
    Today i received my antennas and did further testing.
    With “listnodes” both reiceivers see each other as “Unknown NodeID found: <NodeID>”
    However, trying to exchange keys or starting a chat results in nothing. It just returns to the prompt seemingly doing nothing.
    The file and folder permissions are correct on both sides, the directory containing beechat is owned by the running user, so that shouldn’t be an issue.

    The “ID”s (Extendes PAN ID) are set to the same value, one is configured as “Form Network [1]”, the other as “Join Network [0]”.

    Am i still missing something?

    #661 Reply
    3iWEvuKEag
    Keymaster

    Hi, I’m sorry for the late response, I only just saw this.

    Can you please check that you ordered the correct dongles? Check that they are the exact model name as in the parts list section.

    #664 Reply
    MrWeedster
    Guest

    Yes, i bought the exact same parts as on the partslist (for long range) two times:
    – SparkFun XBee Explorer Dongle
    – XBee 3 PRO ZigBee Module
    – GW.71 2.4/5.8GHz 5dBi Dipole Antenna, RP-SMA(M) Hinged

    If i do a chat directly in the XCTU console it works, but i think its unencrypted.

    #665 Reply
    3iWEvuKEag
    Keymaster

    Have you activated the “API mode without escapes” setting in XCTU? Hope this works

    • This reply was modified 3 months, 3 weeks ago by 3iWEvuKEag.
    #666 Reply
    3iWEvuKEag
    Keymaster

    As a heads up, 2 other developers have joined the development of BeeChat in the last couple of weeks, and we are almost done with a Graphical User Interface which will make all these issues much easier to troubleshoot.

    #708 Reply
    MrWeedster
    Guest

    Yes i have “API mode without escapes” activated.

    #709 Reply
    3iWEvuKEag
    Keymaster

    Can you please get in touch with me on Telegram? My username is https://t.me/iWEvuKEag
    I will try to help you as much as I can, I believe it’s better to chat than to do it on the forum.
    As soon as we find a solution to the issue, I will post the solution here.

    #712 Reply
    3iWEvuKEag
    Keymaster

    Hi MrWeedster, we’re about to release the User Interface version. We’ll upload the new version in a few days.
    Hope you haven’t given up. Here’s the video showing the latest version:
    https://beechat.network/downloads/out.mov

Viewing 15 posts - 1 through 15 (of 15 total)
Reply To: NodeIDs empty
Your information: